Back
Degraded
Degraded
Ongoing investigation into issue related to NordPool and EPEX feeds
Started 22 May at 11:45am BST, last updated 22 May at 11:58am BST.
Production Web Portal
Production Nord Pool Public Feeds
Updated
We have verified that this was a false alarm and no trading activity was impacted.
Posted 22 May at 11:58am BST.
Resolved
We have identified and resolved the issue, thank you for your patience!
Posted 22 May at 11:54am BST.
Created
Brady are actively investigating an ongoing issue related to NordPool and EPEX feeds.
Posted 22 May at 11:45am BST.