Get in touch
Back
Resolved

Brady are investigating an ongoing issue with NordPool Public/Private feeds

Started 20 Jun at 10:34am BST.

Production Nord Pool Public Feeds
Created

Investigation complete and issue resolved with NordPool Public/Private feeds

Posted 20 Jun at 10:34am BST.