Get in touch
Back
Resolved

Brady aware of ongoing Azure Service Issue FVHB-188

Started 5 Jul at 03:38pm BST.

Production Backend
Created

Brady are aware of an ongoing Network Infrastructure issue affecting Azure Services.

Posted 5 Jul at 03:38pm BST.