Get in touch
Back
Maintenance

[EPEX M7] MM7-1 | Maintenance on 22/08/2023

Completed 22 Aug at 09:30pm BST.

Production EPEX M7 Public Feeds
Completed

Maintenance completed

Posted 22 Aug at 09:30pm BST.
Started

Please be informed that the M7 trading system will be under maintenance on 22/08/2023 between 18:40 BST and 21:30 BST.
This maintenance is related to:
• Infrastructure upgrade for performance improvement
• ECC Monthly Maintenance
ComTrader version 6.15.46 will be available for download. This version will become mandatory as of August 22nd.

Posted 22 Aug at 06:40pm BST.