Get in touch
Back
Maintenance

EPEX Test system updates

Completed 16 Nov at 10:30am GMT.

Staging Epex M7 Public Feeds
Completed

Maintenance completed

Posted 16 Nov at 10:30am GMT.
Started

EPEX deployed a new version in the Advanced Simulation environment.

Posted 16 Nov at 09:00am GMT.