Get in touch
Back
Maintenance

[EPEX M7] MM7-1 | Maintenance on 16/01/2024

Completed 16 Jan at 08:39pm GMT.

Production EPEX M7 Public Feeds
Completed

Maintenance completed 20:35 CET

Posted 16 Jan at 08:39pm GMT.
Started

Type M7 maintenance
Maintenance start time 16/01/2024 19:40 CET (18:40 GMT)
Expected end time 16/01/2024 22:15 CET (21:15 GMT)
EPEX market(s) impacted All EPEX Intraday continuous markets
Member impact Members cannot access the M7 trading system

Posted 16 Jan at 06:40pm GMT.