Get in touch
Back
Maintenance

Nordpool Service Break

Completed 5 Mar at 01:00am GMT.

Production Nord Pool Public Feeds
Completed

Maintenance completed

Posted 5 Mar at 01:00am GMT.
Started

Please be advised that Nord Pool has scheduled an intraday maintenance break on Monday 4th March between 22:30 CET – 01:00 CET. During this time no order entry or matching can take place and any open orders in the market will be withdrawn.

Posted 4 Mar at 10:00pm GMT.