Get in touch
Back
Maintenance

Nordpool Intraday Maintenance

Completed 18 Mar at 09:30am GMT.

Production Nord Pool Public Feeds
Completed

Maintenance completed

Posted 18 Mar at 09:30am GMT.
Started

INTRADAY: Scheduled maintenance: Monday 18th March between 08:30 CET and 10:30 CET
During this time no order entry or matching can take place and any open orders in the market will be withdrawn.

Posted 18 Mar at 07:30am GMT.