Back
Maintenance
Maintenance
[EPEX M7] MM7-1 | Maintenance on 11/02/2025
Completed 11 Feb at 09:10pm GMT.
Production EPEX M7 Public Feeds
Completed
Maintenance completed
Posted
11 Feb at 09:10pm GMT.
Started
Type: M7 maintenance
Maintenance start time: 11/02/2025 19:40 CET (18:40 GMT)
Expected end time: 11/02/2025 22:10 CET (21:10 GMT)
EPEX market(s) impacted: All EPEX Intraday continuous markets
Member impact: Members cannot access the M7 trading system
Posted
11 Feb at 06:35pm GMT.