Get in touch
Back
Downtime

Configuration of Shadow Ops environment

Completed 24 Dec at 06:00pm GMT.

Production Web Portal
Completed

Maintenance completed

Posted 24 Dec at 06:00pm GMT.
Updated

Ongoing configuration

Posted 9 Dec at 07:41am GMT.
Started

Initial setup and configuration

Posted 8 Dec at 07:00am GMT.