Back
Resolved
Resolved
INTRADAY CONTINUOUS: Scheduled maintenance: Tuesday 28th of July between 07:30 BST - 09:30 BST
Completed 28 Jul at 09:30am BST.
Production Nord Pool Public Feeds
Completed
Maintenance ended
Posted
28 Jul at 09:30am BST.
Started
Please be advised that Nord Pool has scheduled an intraday maintenance break on Tuesday 28th of July between 07:30 BST - 09:30 BST.
During this time no order entry or matching can take place and any open orders in the market will be deactivated. Please check your order status after maintenance is completed.
Posted
28 Jul at 07:30am BST.